Important Notice: ActiveTail's marketing website is currently unavailable - RESOLVED

Incident Report for ActiveTrail

Resolved

The marketing website is back and fully operational.

Thanks
Posted Mar 25, 2025 - 09:52 IST

Investigating

We are currently investigate this issue,
In the meantime please use the following link to login:

https://app.activetrail.com/Public/Login.aspx?
Posted Mar 25, 2025 - 09:45 IST
This incident affected: Marketing Website (Performance, New account registrations).