RESOLVED - Some clients may experience Temporary Delays in TEST Emails Delivery
Incident Report for ActiveTrail
Resolved
This incident has been resolved.
Posted Jun 13, 2024 - 10:58 IDT
Investigating
Dear Client,

We're currently experiencing TEST email delivery delays.
This means that TEST emails are being sent but at a slow rate.
Our team is continuously working to resolve this issue swiftly.

We apologize for any inconvenience and will keep you updated.

Best Regards,
ActiveTrail team.
Posted Jun 13, 2024 - 10:05 IDT
This incident affected: Email Service (Test Emails).