Important Notice: Some users are experiencing issues with buttons not being clickable - RESOLVED
Incident Report for ActiveTrail
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 11:41 IST
Investigating
Please perform CTRL+ SHIFT + R to resolve this issue locally on your browser
Posted Mar 06, 2024 - 17:04 IST
This incident affected: User Account (General).