Important Notice: Some Clients May Experience Temporary Delays in Emails Delivery - RESOLVED
Incident Report for ActiveTrail
Resolved
Dear client,

The issue has been resolved and the emails are now being sent at a normal pace.

Thank you for your patience.
Posted May 23, 2024 - 16:57 IDT
Investigating
Dear Client,

We're currently experiencing some email delivery delays.
This means that emails are being sent but at a slow rate.
Our team is continuously working to resolve this issue swiftly.

We apologize for any inconvenience and will keep you updated.

Best Regards,
ActiveTrail team.
Posted May 23, 2024 - 14:02 IDT
This incident affected: Email Service (Email sending rate).