Important Notice: Difficulties to open a new account - Resolved
Incident Report for ActiveTrail
Resolved
Please be advised that the issue has been resolved.
You can open a new account with no issues

Thank you
Posted Jan 31, 2024 - 15:01 IST
Update
We are continuing to investigate this issue.
Posted Jan 31, 2024 - 14:25 IST
Investigating
There are currently some issues with new account registrations.
We are working to resolve this as soon as possible.
Posted Jan 31, 2024 - 14:22 IST
This incident affected: Marketing Website (New account registrations).