Important Notice: Some clients may experience slower account performance - RESOLVED

Incident Report for ActiveTrail

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 10:20 IST

Investigating

Dear customers,

We are investigating the slowness in the account's operations.

Thank you
Posted Feb 18, 2026 - 09:40 IST
This incident affected: User Account (Performance).