Important Notice: General slowness in account's operations -RESOLVED
Incident Report for ActiveTrail
Resolved
Dear clients,

Please be advised that the issue has been fully resolved by the tech team.
We will keep monitoring to ensure that everything works properly.

Thank you for your patience.

ActiveTrail Team
Posted Apr 04, 2024 - 13:19 IDT
Investigating
Dear clients,

Some of the clients might experience general slowness with their accounts.

We are further investigating this issue
Posted Apr 04, 2024 - 10:27 IDT
This incident affected: User Account (Login, Performance, General).